IO-Pipely 0.005 Pass

Tested by Chris Williams (BINGOS), 21. Oct 2013,

  1. Program output
  2. Tester comments
  3. Prerequisites
  4. Environment and other context
  5. More reports...

This distribution has been tested as part of the CPAN Testers project, supporting the Perl programming language. See http://wiki.cpantesters.org/ for more information or email questions to cpan-testers-discuss@perl.org

--

Dear Rocco Caputo,

This is a computer-generated error report created automatically by CPANPLUS, version 0.9142. Testers personal comments may appear at the end of this report.

Thank you for uploading your work to CPAN. Congratulations! All tests were successful.

TEST RESULTS:

Below is the error stack from stage 'make test':

PERL_DL_NONLAZY=1 /home/cpan/pit/thr/perl-5.12.3/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t # Perl 5.012003, /home/cpan/pit/thr/perl-5.12.3/bin/perl on openbsd t/00-info-perl.t .......... ok # Testing with Perl 5.012003, /home/cpan/pit/thr/perl-5.12.3/bin/perl # Carp version is 1.32 # Exporter version is 5.68 # ExtUtils::MakeMaker version is 6.78 # Fcntl version is 1.06 # IO::Socket version is 1.31 # Scalar::Util version is 1.35 # Symbol version is 1.07 # Test::More version is 0.98 # base version is 2.18 # strict version is 1.04 # warnings version is 1.09 t/000-report-versions.t ... ok t/01-test-pod.t ........... skipped: RELEASE_TESTING environment variable is not true. t/02-pod-no404s.t ......... skipped: RUN_NETWORK_TESTS environment variable is not true. t/11-pipely-base.t ........ skipped: not implemented yet t/12-pipely-oneway.t ...... ok t/13-pipely-twoway.t ...... ok t/release-pod-coverage.t .. skipped: these tests are for release candidate testing t/release-pod-syntax.t .... skipped: these tests are for release candidate testing All tests successful. Files=9, Tests=23, 1 wallclock secs ( 0.04 usr 0.14 sys + 0.62 cusr 0.12 csys = 0.92 CPU) Result: PASS

PREREQUISITES:

Here is a list of prerequisites you specified and versions we managed to load:

Module Name Have Want ! Carp 1.17 1.26 ! Exporter 5.64_01 5.68 Fcntl 1.06 1.06 IO::Socket 1.31 1.31 ! Scalar::Util 1.22 1.29 Symbol 1.07 1.06 Test::More 0.98 0.98 ! base 2.15 2.18 strict 1.04 0 warnings 1.09 0

Perl module toolchain versions installed: Module Name Have CPANPLUS 0.9142 CPANPLUS::Dist::Build 0.70 Cwd 3.40 ExtUtils::CBuilder 0.280212 ExtUtils::Command 1.16 ExtUtils::Install 1.55 ExtUtils::MakeMaker 6.78 ExtUtils::Manifest 1.63 ExtUtils::ParseXS 3.22 File::Spec 3.40 Module::Build 0.4007 Pod::Parser 1.37 Pod::Simple 3.14 Test::Harness 3.29 Test::More 0.98 version 0.9904

******************************** NOTE ******************************** The comments above are created mechanically, possibly without manual checking by the sender. As there are many people performing automatic tests on each upload to CPAN, it is likely that you will receive identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first one with correction and/or additional informations, and do not take it personally. We appreciate your patience. :) **********************************************************************

Additional comments:

This report was machine-generated by CPANPLUS::Dist::YACSmoke 0.90. Powered by minismokebox version 0.58

Program output



  

Prerequisites

Requires

Build requires

Configure requires

Tester comments

Environment and other context

Environment variables:

    AUTOMATED_TESTING = 1
    NONINTERACTIVE_TESTING = 1
    PATH = /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/script:/home/cpan/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin:/usr/games:.
    PERL5LIB = :/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-IP-Minimal-0.06/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-IP-Minimal-0.06/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-Netmask-1.9019/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-Netmask-1.9019/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Carp-1.32/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Carp-1.32/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Exporter-5.68/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Exporter-5.68/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Scalar-List-Utils-1.35/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Scalar-List-Utils-1.35/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/base-2.18/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/base-2.18/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/IO-Pipely-0.005/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/IO-Pipely-0.005/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 78
    PERL5_CPANPLUS_IS_VERSION = 0.9142
    PERL5_MINISMOKEBOX = 0.58
    PERL5_YACSMOKE_BASE = /home/cpan/pit/thr/conf/perl-5.12.3
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/local/bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /home/cpan/pit/thr/perl-5.12.3/bin/perl
    UID:  $<  = 1001
    EUID: $>  = 1001
    GID:  $(  = 1001 1001
    EGID: $)  = 1001 1001


-------------------------------


--

Summary of my perl5 (revision 5 version 12 subversion 3) configuration:
   
  Platform:
    osname=openbsd, osvers=5.2, archname=OpenBSD.amd64-openbsd-thread-multi
    uname='openbsd ottoman.bingosnet.co.uk 5.2 generic#309 amd64 '
    config_args='-des -Dprefix=/home/cpan/pit/thr/perl-5.12.3 -Dusethreads'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=y, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-pthread -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include',
    optimize='-O2',
    cppflags='-pthread -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.2.1 20070719 ', gccosandvers='openbsd5.2'
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-pthread -Wl,-E  -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib
    libs=-lgdbm -lm -lutil -lc
    perllibs=-lm -lutil -lc
    libc=/usr/lib/libc.so.65.0, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC ', lddlflags='-shared -fPIC  -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY MYMALLOC PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API
  Built under openbsd
  Compiled at Nov  7 2012 00:14:05
  %ENV:
    PERL5LIB=":/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-IP-Minimal-0.06/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-IP-Minimal-0.06/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-Netmask-1.9019/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-Netmask-1.9019/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Carp-1.32/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Carp-1.32/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Exporter-5.68/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Exporter-5.68/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Scalar-List-Utils-1.35/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Scalar-List-Utils-1.35/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/base-2.18/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/base-2.18/blib/arch:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/IO-Pipely-0.005/blib/lib:/home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/IO-Pipely-0.005/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="78"
    PERL5_CPANPLUS_IS_VERSION="0.9142"
    PERL5_MINISMOKEBOX="0.58"
    PERL5_YACSMOKE_BASE="/home/cpan/pit/thr/conf/perl-5.12.3"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-IP-Minimal-0.06/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-IP-Minimal-0.06/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-Netmask-1.9019/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Net-Netmask-1.9019/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/POE-Test-Loops-1.354/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Carp-1.32/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Carp-1.32/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Exporter-5.68/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Exporter-5.68/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Scalar-List-Utils-1.35/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/Scalar-List-Utils-1.35/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/base-2.18/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/base-2.18/blib/arch
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/IO-Pipely-0.005/blib/lib
    /home/cpan/pit/thr/conf/perl-5.12.3/.cpanplus/5.12.3/build/IO-Pipely-0.005/blib/arch
    /home/cpan/pit/thr/perl-5.12.3/lib/site_perl/5.12.3/OpenBSD.amd64-openbsd-thread-multi
    /home/cpan/pit/thr/perl-5.12.3/lib/site_perl/5.12.3
    /home/cpan/pit/thr/perl-5.12.3/lib/5.12.3/OpenBSD.amd64-openbsd-thread-multi
    /home/cpan/pit/thr/perl-5.12.3/lib/5.12.3