App-prowess 0.05 Pass

Tested by Chris Williams (BINGOS), 24. Jun 2017,

  1. Program output
  2. Tester comments
  3. Prerequisites
  4. Environment and other context
  5. More reports...

This distribution has been tested as part of the CPAN Testers project, supporting the Perl programming language. See http://wiki.cpantesters.org/ for more information or email questions to cpan-testers-discuss@perl.org

--

Dear JHTHORSEN,

This is a computer-generated error report created automatically by CPANPLUS, version 0.9168. Testers personal comments may appear at the end of this report.

Thank you for uploading your work to CPAN. Congratulations! All tests were successful.

TEST RESULTS:

Below is the error stack from stage 'make test':

PERL_DL_NONLAZY=1 "/usr/home/cpan/pit/bare/perl-5.8.9/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-basic.t .... ok t/parse_argv.t .. ok # sleep 0 # utime 1497911070, 1497911070, t/run.t # sleep 3 # utime 1497911074, 1497911074, t/run.t t/run.t ......... ok All tests successful. Files=3, Tests=17, 1 wallclock secs ( 0.03 usr 0.04 sys + 0.26 cusr 0.23 csys = 0.55 CPU) Result: PASS

PREREQUISITES:

Here is a list of prerequisites you specified and versions we managed to load:

Module Name Have Want App::Prove 3.39 3.35 Filesys::Notify::Simple 0.12 0.12 Test::More 1.302085 0.88

Perl module toolchain versions installed: Module Name Have CPANPLUS 0.9168 CPANPLUS::Dist::Build 0.88 Cwd 3.62 ExtUtils::CBuilder 0.280224 ExtUtils::Command 7.28 ExtUtils::Install 2.14 ExtUtils::MakeMaker 7.28 ExtUtils::Manifest 1.70 ExtUtils::ParseXS 3.30 File::Spec 3.62 Module::Build 0.4224 Pod::Parser 1.35 Pod::Simple 3.35 Test2 1.302085 Test::Harness 3.39 Test::More 1.302085 version 0.9918

******************************** NOTE ******************************** The comments above are created mechanically, possibly without manual checking by the sender. As there are many people performing automatic tests on each upload to CPAN, it is likely that you will receive identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first one with correction and/or additional informations, and do not take it personally. We appreciate your patience. :) **********************************************************************

Additional comments:

This report was machine-generated by CPANPLUS::Dist::YACSmoke 1.02. Powered by minismokebox version 0.68

Program output



  

Prerequisites

Requires

Build requires

Configure requires

Tester comments

Environment and other context

Environment variables:

    AUTOMATED_TESTING = 1
    NONINTERACTIVE_TESTING = 1
    PATH = /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/script:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/cpan/bin
    PERL5LIB = :/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/hGckNU6LOo/Test-Requires-0.10/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/hGckNU6LOo/Test-Requires-0.10/blib/arch:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/M574yTne6F/Test-SharedFork-0.35/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/M574yTne6F/Test-SharedFork-0.35/blib/arch:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/0gJMIagdtA/Filesys-Notify-Simple-0.12/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/0gJMIagdtA/Filesys-Notify-Simple-0.12/blib/arch:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 2629
    PERL5_CPANPLUS_IS_VERSION = 0.9168
    PERL5_MINISMOKEBOX = 0.68
    PERL5_YACSMOKE_BASE = /usr/home/cpan/pit/bare/conf/perl-5.8.9
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/local/bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /usr/home/cpan/pit/bare/perl-5.8.9/bin/perl
    UID:  $<  = 1002
    EUID: $>  = 1002
    GID:  $(  = 1002 1002
    EGID: $)  = 1002 1002


-------------------------------


--

Summary of my perl5 (revision 5 version 8 subversion 9) configuration:
  Platform:
    osname=freebsd, osvers=11.0-release-p1, archname=amd64-freebsd
    uname='freebsd fforc 11.0-release-p1 freebsd 11.0-release-p1 #0 r306420: thu sep 29 01:43:23 utc 2016 root@releng2.nyi.freebsd.org:usrobjusrsrcsysgeneric amd64 '
    config_args='-des -Dprefix=/usr/home/cpan/pit/bare/perl-5.8.9'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include',
    optimize='-O',
    cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='4.2.1 Compatible FreeBSD Clang 3.8.0 (tags/RELEASE_380/final 262564)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-Wl,-E  -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lgdbm -lm -lcrypt -lutil -lc
    perllibs=-lm -lcrypt -lutil -lc
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC', lddlflags='-shared  -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT
                        USE_FAST_STDIO USE_LARGE_FILES USE_PERLIO
  Locally applied patches:
	Devel::PatchPerl 1.48
  Built under freebsd
  Compiled at Mar 15 2017 12:36:48
  %ENV:
    PERL5LIB=":/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/hGckNU6LOo/Test-Requires-0.10/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/hGckNU6LOo/Test-Requires-0.10/blib/arch:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/M574yTne6F/Test-SharedFork-0.35/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/M574yTne6F/Test-SharedFork-0.35/blib/arch:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/0gJMIagdtA/Filesys-Notify-Simple-0.12/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/0gJMIagdtA/Filesys-Notify-Simple-0.12/blib/arch:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/lib:/usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="2629"
    PERL5_CPANPLUS_IS_VERSION="0.9168"
    PERL5_MINISMOKEBOX="0.68"
    PERL5_YACSMOKE_BASE="/usr/home/cpan/pit/bare/conf/perl-5.8.9"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/hGckNU6LOo/Test-Requires-0.10/blib/lib
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/hGckNU6LOo/Test-Requires-0.10/blib/arch
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/M574yTne6F/Test-SharedFork-0.35/blib/lib
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/M574yTne6F/Test-SharedFork-0.35/blib/arch
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/0gJMIagdtA/Filesys-Notify-Simple-0.12/blib/lib
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/0gJMIagdtA/Filesys-Notify-Simple-0.12/blib/arch
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/lib
    /usr/home/cpan/pit/bare/conf/perl-5.8.9/.cpanplus/5.8.9/build/DadUqQFFNf/App-prowess-0.05/blib/arch
    /usr/home/cpan/pit/bare/perl-5.8.9/lib/5.8.9/amd64-freebsd
    /usr/home/cpan/pit/bare/perl-5.8.9/lib/5.8.9
    /usr/home/cpan/pit/bare/perl-5.8.9/lib/site_perl/5.8.9/amd64-freebsd
    /usr/home/cpan/pit/bare/perl-5.8.9/lib/site_perl/5.8.9