Mojolicious-Plugin-OpenAPI 2.14 Pass

Tested by Nigel Horne, 24. Jun 2019,

  1. Program output
  2. Tester comments
  3. Prerequisites
  4. Environment and other context
  5. More reports...

This distribution has been tested as part of the CPAN Testers project, supporting the Perl programming language. See http://wiki.cpantesters.org/ for more information or email questions to cpan-testers-discuss@perl.org

-- Dear Jan Henning Thorsen,

This is a computer-generated report for Mojolicious-Plugin-OpenAPI-2.14 on perl 5.16.3, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN. Congratulations! All tests were successful

Program output

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/home/njh/perl5/perlbrew/perls/perl-5.16.3/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic.t .......................... ok
t/authenticate.t ...................... ok
t/autorender.t ........................ ok
t/bundle.t ............................ ok
t/coerce.t ............................ ok
t/collectionformat.t .................. ok
t/correct-order-of-paths.t ............ ok
$c->openapi->cors_simple() has been replaced by $c->openapi->cors_exchange() at /tmp/build/Mojolicious-Plugin-OpenAPI-2.14-3/blib/lib/Mojolicious/Plugin/OpenAPI/Cors.pm line 85.
$c->openapi->cors_simple() has been replaced by $c->openapi->cors_exchange() at /tmp/build/Mojolicious-Plugin-OpenAPI-2.14-3/blib/lib/Mojolicious/Plugin/OpenAPI/Cors.pm line 85.
$c->openapi->cors_simple() has been replaced by $c->openapi->cors_exchange() at /tmp/build/Mojolicious-Plugin-OpenAPI-2.14-3/blib/lib/Mojolicious/Plugin/OpenAPI/Cors.pm line 85.
t/cors.t .............................. ok
t/custom-format.t ..................... ok
t/default-value.t ..................... ok
t/discriminator.t ..................... ok
t/empty-string.t ...................... ok
t/error-messages.t .................... ok
t/example-array-of-hashes.t ........... ok
t/headers.t ........................... ok
t/invalid-json.t ...................... ok
t/invalid-x-mojo-name.t ............... ok
t/issue-24-booleans-in-yaml-schema.t .. ok
t/issue-48-refs.t ..................... ok
t/load-and-validate-spec.t ............ ok
t/load-from-app.t ..................... skipped: [JSON::Validator] GET http://127.0.0.1:36131/api == Service Unavailable at /tmp/build/JSON-Validator-3.11-3/blib/lib/JSON/Validator.pm line 378.
t/path-parameters.t ................... ok
t/recursion.t ......................... ok
t/ref-param.t ......................... ok
t/register.t .......................... ok
t/renderer.t .......................... ok
t/reply-spec.t ........................ ok
t/route-names.t ....................... ok
t/security-disabled.t ................. ok
t/security.t .......................... ok
t/set-request.t ....................... ok
t/spec.t .............................. ok
t/swagger2.t .......................... ok
t/tutorial.t .......................... ok
t/v2-file.t ........................... ok
Format rule for 'unknown' is missing at /tmp/build/JSON-Validator-3.11-3/blib/lib/JSON/Validator.pm line 747.
t/v2-formats.t ........................ ok
t/v2-readonly.t ....................... ok
t/v3-body.t ........................... ok
t/v3-nullable.t ....................... ok
t/v3.t ................................ ok
t/validate.t .......................... ok
t/x-mojo-placeholder.t ................ ok
# YAML::XS 0.76
t/yaml.t .............................. ok
All tests successful.

Test Summary Report
-------------------
t/v2-formats.t                      (Wstat: 0 Tests: 30 Failed: 0)
  TODO passed:   15, 21-22
Files=43, Tests=624, 187 wallclock secs ( 0.88 usr  0.78 sys + 125.28 cusr 23.56 csys = 150.50 CPU)
Result: PASS

Prerequisites

Requires

Build requires

Configure requires

Tester comments

this report is from an automated smoke testing program and was not reviewed by a human for accuracy

Environment and other context

Environment variables:

    AUTOMATED_TESTING = 1
    PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.16.3/bin:src/njh/smoker/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin
    PERL5LIB = /tmp/build/JSON-Validator-3.11-3/blib/arch:/tmp/build/JSON-Validator-3.11-3/blib/lib:/tmp/build/Mojolicious-8.17-3/blib/arch:/tmp/build/Mojolicious-8.17-3/blib/lib:/tmp/build/Scalar-List-Utils-1.50-2/blib/arch:/tmp/build/Scalar-List-Utils-1.50-2/blib/lib:/tmp/build/IO-Socket-IP-0.39-1/blib/arch:/tmp/build/IO-Socket-IP-0.39-1/blib/lib:/tmp/build/File-ShareDir-Install-0.13-2/blib/arch:/tmp/build/File-ShareDir-Install-0.13-2/blib/lib
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 84920
    PERL5_CPAN_IS_RUNNING = 84920
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 89588,84920
    PERLBREW_HOME = /home/njh/.perlbrew
    PERLBREW_MANPATH = /home/njh/perl5/perlbrew/perls/perl-5.16.3/man
    PERLBREW_PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.16.3/bin
    PERLBREW_PERL = perl-5.16.3
    PERLBREW_ROOT = /home/njh/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.84
    PERLBREW_VERSION = 0.84
    SHELL = /bin/sh
    TMPDIR = /tmp/testwrapper.66053

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/njh/perl5/perlbrew/perls/perl-5.16.3/bin/perl
    $UID/$EUID = 1000 / 1000
    $GID = 1000 1000 0
    $EGID = 1000 1000 0

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.16    
    CPAN::Meta          2.143240
    Cwd                 3.39_02 
    ExtUtils::CBuilder  0.280206
    ExtUtils::Command   7.30    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.30    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.16    
    File::Spec          3.39_02 
    JSON                2.97001 
    JSON::PP            2.27203 
    Module::Build       0.39_01 
    Module::Signature   n/a     
    Parse::CPAN::Meta   1.4414  
    Test::Harness       3.39    
    Test::More          1.302122
    YAML                1.27    
    YAML::Syck          1.30    
    version             0.99    


--

Summary of my perl5 (revision 5 version 16 subversion 3) configuration:
   
  Platform:
    osname=openbsd, osvers=6.2, archname=OpenBSD.amd64-openbsd
    uname='openbsd netgate1.bandsman.co.uk 6.2 generic.mp#2 amd64 '
    config_args='-de -Dprefix=/home/njh/perl5/perlbrew/perls/perl-5.16.3 -Aeval:scriptdir=/home/njh/perl5/perlbrew/perls/perl-5.16.3/bin'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include',
    optimize='-O2',
    cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.2.1 Compatible OpenBSD Clang 4.0.0 (tags/RELEASE_400/final)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-Wl,-E  -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib
    libs=-lm -lutil -lc
    perllibs=-lm -lutil -lc
    libc=/usr/lib/libc.so.90.0, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC ', lddlflags='-shared -fPIC  -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES PERLIO_LAYERS PERL_DONT_CREATE_GVSV
                        PERL_MALLOC_WRAP PERL_PRESERVE_IVUV USE_64_BIT_ALL
                        USE_64_BIT_INT USE_LARGE_FILES USE_LOCALE
                        USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF
  Locally applied patches:
	Devel::PatchPerl 1.48
  Built under openbsd
  Compiled at Feb  6 2018 11:05:56
  %ENV:
    PERL5LIB="/tmp/build/JSON-Validator-3.11-3/blib/arch:/tmp/build/JSON-Validator-3.11-3/blib/lib:/tmp/build/Mojolicious-8.17-3/blib/arch:/tmp/build/Mojolicious-8.17-3/blib/lib:/tmp/build/Scalar-List-Utils-1.50-2/blib/arch:/tmp/build/Scalar-List-Utils-1.50-2/blib/lib:/tmp/build/IO-Socket-IP-0.39-1/blib/arch:/tmp/build/IO-Socket-IP-0.39-1/blib/lib:/tmp/build/File-ShareDir-Install-0.13-2/blib/arch:/tmp/build/File-ShareDir-Install-0.13-2/blib/lib"
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="84920"
    PERL5_CPAN_IS_RUNNING="84920"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="89588,84920"
    PERLBREW_HOME="/home/njh/.perlbrew"
    PERLBREW_MANPATH="/home/njh/perl5/perlbrew/perls/perl-5.16.3/man"
    PERLBREW_PATH="/home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.16.3/bin"
    PERLBREW_PERL="perl-5.16.3"
    PERLBREW_ROOT="/home/njh/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.84"
    PERLBREW_VERSION="0.84"
  @INC:
    /tmp/build/JSON-Validator-3.11-3/blib/arch
    /tmp/build/JSON-Validator-3.11-3/blib/lib
    /tmp/build/Mojolicious-8.17-3/blib/arch
    /tmp/build/Mojolicious-8.17-3/blib/lib
    /tmp/build/Scalar-List-Utils-1.50-2/blib/arch
    /tmp/build/Scalar-List-Utils-1.50-2/blib/lib
    /tmp/build/IO-Socket-IP-0.39-1/blib/arch
    /tmp/build/IO-Socket-IP-0.39-1/blib/lib
    /tmp/build/File-ShareDir-Install-0.13-2/blib/arch
    /tmp/build/File-ShareDir-Install-0.13-2/blib/lib
    /home/njh/perl5/perlbrew/perls/perl-5.16.3/lib/site_perl/5.16.3/OpenBSD.amd64-openbsd
    /home/njh/perl5/perlbrew/perls/perl-5.16.3/lib/site_perl/5.16.3
    /home/njh/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3/OpenBSD.amd64-openbsd
    /home/njh/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3