Mojolicious-Plugin-OpenAPI 2.00 Pass

Tested by Serguei Trouchelle (STRO), 21. Oct 2018,

  1. Program output
  2. Tester comments
  3. Prerequisites
  4. Environment and other context
  5. More reports...

This distribution has been tested as part of the CPAN Testers project, supporting the Perl programming language. See http://wiki.cpantesters.org/ for more information or email questions to cpan-testers-discuss@perl.org

-- Dear Jan Henning Thorsen,

This is a computer-generated report for Mojolicious-Plugin-OpenAPI-2.00 on perl 5.29.3, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN. Congratulations! All tests were successful

Program output

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/home/stro/perl/5.29.3m/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic.t .......................... ok
t/authenticate.t ...................... ok
t/autorender.t ........................ ok
t/coerce.t ............................ ok
t/collectionformat.t .................. ok
t/correct-order-of-paths.t ............ ok
t/default-value.t ..................... ok
t/discriminator.t ..................... ok
t/empty-string.t ...................... ok
t/error-messages.t .................... ok
t/example-array-of-hashes.t ........... ok
t/formats.t ........................... ok
t/headers.t ........................... ok
t/invalid-json.t ...................... ok
t/invalid-x-mojo-name.t ............... ok
t/issue-24-booleans-in-yaml-schema.t .. skipped: [JSON::Validator] The optional YAML::XS module is missing or could not be loaded: Can't locate YAML/XS.pm in @INC (you may need to install the YAML::XS module) (@INC contains: /home/stro/cpan/build/5.29.3m/build/Mojolicious-Plugin-OpenAPI-2.00-0/blib/lib /home/stro/cpan/build/5.29.3m/build/Mojolicious-Plugin-OpenAPI-2.00-0/blib/arch /home/stro/perl/5.29.3m/lib/site_perl/5.29.3/i86pc-solaris-multi /home/stro/perl/5.29.3m/lib/site_perl/5.29.3 /home/stro/perl/5.29.3m/lib/5.29.3/i86pc-solaris-multi /home/stro/perl/5.29.3m/lib/5.29.3 .) at (eval 69) line 1.
t/issue-48-refs.t ..................... ok
t/path-parameters.t ................... ok
t/ref-param.t ......................... ok
t/register.t .......................... ok
t/renderer.t .......................... ok
t/reply-spec.t ........................ ok
t/route-names.t ....................... ok
t/security-disabled.t ................. ok
t/security.t .......................... ok
t/set-request.t ....................... ok
t/simple-cors.t ....................... ok
t/spec.t .............................. ok
t/swagger2.t .......................... ok
t/tutorial.t .......................... ok
t/validate.t .......................... ok
t/x-mojo-placeholder.t ................ ok
# Skipping test when YAML::XS 0.67 is not installed
t/yaml.t .............................. ok
All tests successful.
Files=33, Tests=381, 15 wallclock secs ( 0.11 usr  0.04 sys + 13.21 cusr  1.61 csys = 14.97 CPU)
Result: PASS

Prerequisites

Requires

Build requires

Configure requires

Tester comments

this report is from an automated smoke testing program and was not reviewed by a human for accuracy

Environment and other context

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_US.UTF-8
    PATH = /usr/gnu/bin:/usr/bin:/usr/sbin:/sbin:/usr/sfw/bin:
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 24367
    PERL5_CPAN_IS_RUNNING = 24367
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 20848,24367
    PERL_CR_SMOKER_CURRENT = Slovo-2018.10.11
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /bin/bash
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/stro/perl/5.29.3m/bin/perl
    $UID/$EUID = 101 / 101
    $GID = 10 10
    $EGID = 10 10

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.20    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280230
    ExtUtils::Command   7.34    
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.34    
    ExtUtils::Manifest  1.71    
    ExtUtils::ParseXS   3.39    
    File::Spec          3.75    
    JSON                2.97001 
    JSON::PP            2.97001 
    Module::Build       0.4224  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302140
    YAML                1.26    
    YAML::Syck          1.30    
    version             0.9924  


--

Summary of my perl5 (revision 5 version 29 subversion 3) configuration:
   
  Platform:
    osname=solaris
    osvers=2.11
    archname=i86pc-solaris-multi
    uname='sunos vm-openindiana-001 5.11 illumos-ed992b0aac i86pc i386 i86pc solaris '
    config_args=''
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=define
    use64bitint=undef
    use64bitall=undef
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='/opt/SUNWspro/bin/cc'
    ccflags ='-I/usr/gnu/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DPERL_USE_SAFE_PUTENV'
    optimize='-O'
    cppflags='-I/usr/gnu/include'
    ccversion='Sun C 5.10 SunOS_i386 2009/06/03'
    gccversion=''
    gccosandvers=''
    intsize=4
    longsize=4
    ptrsize=4
    doublesize=8
    byteorder=1234
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=12
    longdblkind=3
    ivtype='long'
    ivsize=4
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=4
    prototype=define
  Linker and Libraries:
    ld='/opt/SUNWspro/bin/cc'
    ldflags =' -L/usr/lib -L/usr/ccs/lib -L/opt/sunstudio12.1/prod/lib -L/lib -L/usr/gnu/lib '
    libpth=/usr/lib /usr/ccs/lib /opt/sunstudio12.1/prod/lib /lib /usr/gnu/lib
    libs=-lpthread -lsocket -lnsl -lgdbm -ldb -ldl -lm -lc
    perllibs=-lpthread -lsocket -lnsl -ldl -lm -lc
    libc=/lib/libc.so
    so=so
    useshrplib=true
    libperl=libperl.so
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='  -R /home/stro/perl/5.29.3m/lib/5.29.3/i86pc-solaris-multi/CORE'
    cccdlflags='-KPIC'
    lddlflags='-G -L/usr/lib -L/usr/ccs/lib -L/opt/sunstudio12.1/prod/lib -L/lib -L/usr/gnu/lib'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    MULTIPLICITY
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_IMPLICIT_CONTEXT
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    PERL_USE_SAFE_PUTENV
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Built under solaris
  Compiled at Oct 18 2018 07:18:17
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="24367"
    PERL5_CPAN_IS_RUNNING="24367"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="20848,24367"
    PERL_CR_SMOKER_CURRENT="Slovo-2018.10.11"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /home/stro/perl/5.29.3m/lib/site_perl/5.29.3/i86pc-solaris-multi
    /home/stro/perl/5.29.3m/lib/site_perl/5.29.3
    /home/stro/perl/5.29.3m/lib/5.29.3/i86pc-solaris-multi
    /home/stro/perl/5.29.3m/lib/5.29.3