App-sslmaker 0.13 Fail

Tested by Alceu Rodrigues de Freitas Junior, 27. Dec 2017,

  1. Program output
  2. Tester comments
  3. Prerequisites
  4. Environment and other context
  5. More reports...

This distribution has been tested as part of the CPAN Testers project, supporting the Perl programming language. See http://wiki.cpantesters.org/ for more information or email questions to cpan-testers-discuss@perl.org

-- Dear Jan Henning Thorsen,

This is a computer-generated report for App-sslmaker-0.13 on perl 5.26.1, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN. However, there was a problem testing your distribution.

If you think this report is invalid, please consult the CPAN Testers Wiki for suggestions on how to avoid getting FAIL reports for missing library or binary dependencies, unsupported operating systems, and so on:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Program output

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/home/goku/perl5/perlbrew/perls/perl-5.26.1/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic.t ...................................... ok
t/act-as-your-own-certificate-authority.t ......... ok
# tested in t/act-as-your-own-certificate-authority.t
# make intermediate
Error rename on '/tmp/TNqLbb55RG' -> '/tmp/intermediate.cert.pem': Operation not permitted at t/create-an-intermediate-certificate-authority.t line 73.
# Tests were run but no plan was declared and done_testing() was not seen.
# Looks like your test exited with 1 just after 8.
t/create-an-intermediate-certificate-authority.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
All 8 subtests passed 
# Trying to connect to server (79166)
# Waiting for client to connect
# /C=NO/ST=Oslo/L=Oslo/O=Example/OU=Prime/CN=client.example.com/emailAddress=admin@example.com
# Waiting for client to connect
t/real.t .......................................... ok
t/sslmaker-exe.t .................................. skipped: linux is required
t/synopsis.t ...................................... skipped: Need /etc/openssl/openssl.cnf
t/utils.t ......................................... ok

Test Summary Report
-------------------
t/create-an-intermediate-certificate-authority.t (Wstat: 256 Tests: 8 Failed: 0)
  Non-zero exit status: 1
  Parse errors: No plan found in TAP output
Files=7, Tests=48,  3 wallclock secs ( 0.02 usr  0.07 sys +  0.83 cusr  0.91 csys =  1.83 CPU)
Result: FAIL
Failed 1/7 test programs. 0/48 subtests failed.
*** Error 255 in /mnt/cpan_build_dir/goku/App-sslmaker-0.13-0 (Makefile:875 'test_dynamic

Prerequisites

Requires

Build requires

Configure requires

Tester comments

this report is from an automated smoke testing program and was not reviewed by a human for accuracy

Environment and other context

Environment variables:

    AUTOMATED_TESTING = 1
    DBD_MYSQL_TESTDB = test
    DBD_MYSQL_TESTHOST = localhost
    DBD_MYSQL_TESTPASSWORD = 
    DBD_MYSQL_TESTPORT = 3306
    DBD_MYSQL_TESTUSER = goku
    EXTENDED_TESTING = 1
    PATH = /home/goku/perl5/perlbrew/bin:/home/goku/perl5/perlbrew/perls/perl-5.26.1/bin:/home/goku/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 31661
    PERL5_CPAN_IS_RUNNING = 31661
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 6888,31661
    PERLBREW_HOME = /home/goku/.perlbrew
    PERLBREW_MANPATH = /home/goku/perl5/perlbrew/perls/perl-5.26.1/man
    PERLBREW_PATH = /home/goku/perl5/perlbrew/bin:/home/goku/perl5/perlbrew/perls/perl-5.26.1/bin
    PERLBREW_PERL = perl-5.26.1
    PERLBREW_ROOT = /home/goku/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.82
    PERLBREW_VERSION = 0.82
    PERL_CR_SMOKER_CURRENT = App-sslmaker-0.13
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/local/bin/bash
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/goku/perl5/perlbrew/perls/perl-5.26.1/bin/perl
    $UID/$EUID = 1001 / 1001
    $GID = 998 998 1001
    $EGID = 998 998 1001

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.16    
    CPAN::Meta          2.150010
    Cwd                 3.67    
    ExtUtils::CBuilder  0.280230
    ExtUtils::Command   7.31_05 
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.31_05 
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.35    
    File::Spec          3.67    
    JSON                2.97001 
    JSON::PP            2.97001 
    Module::Build       0.4224  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.39    
    Test::More          1.302120
    YAML                1.24    
    YAML::Syck          1.30    
    version             0.9918  


--

Summary of my perl5 (revision 5 version 26 subversion 1) configuration:
   
  Platform:
    osname=openbsd
    osvers=6.2
    archname=OpenBSD.amd64-openbsd
    uname='openbsd cpan-smoker-openbsd 6.2 generic.mp#134 amd64 '
    config_args='-de -Dprefix=/home/goku/perl5/perlbrew/perls/perl-5.26.1 -Aeval:scriptdir=/home/goku/perl5/perlbrew/perls/perl-5.26.1/bin'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='cc'
    ccflags ='-fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2'
    optimize='-O2'
    cppflags='-fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='4.2.1 Compatible OpenBSD Clang 4.0.0 (tags/RELEASE_400/final)'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags ='-Wl,-E  -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lpthread -lm -lutil -lc
    perllibs=-lpthread -lm -lutil -lc
    libc=/usr/lib/libc.so.90.0
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags=' '
    cccdlflags='-DPIC -fPIC '
    lddlflags='-shared -fPIC  -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Locally applied patches:
    Devel::PatchPerl 1.48
  Built under openbsd
  Compiled at Dec 20 2017 18:45:59
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="31661"
    PERL5_CPAN_IS_RUNNING="31661"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="6888,31661"
    PERLBREW_HOME="/home/goku/.perlbrew"
    PERLBREW_MANPATH="/home/goku/perl5/perlbrew/perls/perl-5.26.1/man"
    PERLBREW_PATH="/home/goku/perl5/perlbrew/bin:/home/goku/perl5/perlbrew/perls/perl-5.26.1/bin"
    PERLBREW_PERL="perl-5.26.1"
    PERLBREW_ROOT="/home/goku/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.82"
    PERLBREW_VERSION="0.82"
    PERL_CR_SMOKER_CURRENT="App-sslmaker-0.13"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/goku/perl5/perlbrew/perls/perl-5.26.1/lib/site_perl/5.26.1/OpenBSD.amd64-openbsd
    /home/goku/perl5/perlbrew/perls/perl-5.26.1/lib/site_perl/5.26.1
    /home/goku/perl5/perlbrew/perls/perl-5.26.1/lib/5.26.1/OpenBSD.amd64-openbsd
    /home/goku/perl5/perlbrew/perls/perl-5.26.1/lib/5.26.1