Mojolicious 8.01 Na

Tested by Nigel Horne, 28. Sep, 13:51,

  1. Program output
  2. Tester comments
  3. Prerequisites
  4. Environment and other context
  5. More reports...

This distribution has been tested as part of the CPAN Testers project, supporting the Perl programming language. See http://wiki.cpantesters.org/ for more information or email questions to cpan-testers-discuss@perl.org

-- Dear Sebastian Riedel,

This is a computer-generated report for Mojolicious-8.01 on perl 5.8.4, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN. While attempting to build or test this distribution, the distribution signaled that support is not available either for this operating system or this version of Perl. Nevertheless, any diagnostic output produced is provided below for reference. If this is not what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Program output

Output from '/home/njh/perl5/perlbrew/perls/perl-5.8.4/bin/perl Makefile.PL':

Perl v5.10.1 required--this is only v5.8.4, stopped at Makefile.PL line 1.
BEGIN failed--compilation aborted at Makefile.PL line 1

Prerequisites

Requires

Build requires

Configure requires

Tester comments

this report is from an automated smoke testing program and was not reviewed by a human for accuracy

Environment and other context

Environment variables:

    AUTOMATED_TESTING = 1
    HARNESS_OPTIONS = j2
    LANG = en_GB.UTF-8
    LANGUAGE = en_GB:en
    PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.4/bin:/home/njh/src/njh/smoker/bin:/usr/bin:/bin
    PERL = /home/njh/perl5/perlbrew/perls/perl-5.8.4/bin/perl
    PERL5LIB = 
    PERL5OPT = -I/tmp/user/1000/testwrapper.25936/CPAN-Reporter-lib-1kYK -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 25952
    PERL5_CPAN_IS_EXECUTING = /home/njh/.cpan/build/Mojolicious-8.01-9/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 25952
    PERLBREW_HOME = /home/njh/.perlbrew
    PERLBREW_MANPATH = /home/njh/perl5/perlbrew/perls/perl-5.8.4/man
    PERLBREW_PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.4/bin
    PERLBREW_PERL = perl-5.8.4
    PERLBREW_ROOT = /home/njh/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.83
    PERLBREW_VERSION = 0.83
    PERL_AUTOINSTALL = --defaultdeps
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    SHELL = /bin/sh
    TEMP = /tmp/user/1000
    TMPDIR = /tmp/user/1000/testwrapper.25936

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/njh/perl5/perlbrew/perls/perl-5.8.4/bin/perl
    $UID/$EUID = 1000 / 1000
    $GID = 1000 1000 127 116 108 103 46 44 30 29 25 24 4
    $EGID = 1000 1000 127 116 108 103 46 44 30 29 25 24 4

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.16    
    CPAN::Meta          2.150005
    Cwd                 3.62    
    ExtUtils::CBuilder  0.280224
    ExtUtils::Command   7.22    
    ExtUtils::Install   2.04    
    ExtUtils::MakeMaker 7.22    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.30    
    File::Spec          3.62    
    JSON                2.90    
    JSON::PP            2.27400 
    Module::Build       0.4218  
    Module::Signature   0.80    
    Parse::CPAN::Meta   1.4422  
    Test::Harness       3.36    
    Test::More          1.302037
    YAML                n/a     
    YAML::Syck          1.30    
    version             0.9917  


--

Summary of my perl5 (revision 5 version 8 subversion 4) configuration:
  Platform:
    osname=linux, osvers=3.16.0-4-amd64, archname=x86_64-linux-thread-multi
    uname='linux compaq 3.16.0-4-amd64 #1 smp debian 3.16.7-ckt2-1 (2014-12-08) x86_64 gnulinux '
    config_args='-de -Dprefix=/home/njh/perl5/perlbrew/perls/perl-5.8.4 -Duseithreads -Dusemultiplicity -Dusedevel -Accflags= -Aeval:scriptdir=/home/njh/perl5/perlbrew/perls/perl-5.8.4/bin'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=define use5005threads=undef useithreads=define usemultiplicity=define
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -I/usr/local/include'
    ccversion='', gccversion='4.9.2', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc -lgdbm_compat
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc -lgdbm_compat
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.19'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY USE_ITHREADS USE_64_BIT_INT USE_64_BIT_ALL USE_LARGE_FILES PERL_IMPLICIT_CONTEXT
  Built under linux
  Compiled at Jan 22 2015 00:57:08
  %ENV:
    PERL="/home/njh/perl5/perlbrew/perls/perl-5.8.4/bin/perl"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="25952"
    PERL5_CPAN_IS_EXECUTING="/home/njh/.cpan/build/Mojolicious-8.01-9/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="25952"
    PERLBREW_HOME="/home/njh/.perlbrew"
    PERLBREW_MANPATH="/home/njh/perl5/perlbrew/perls/perl-5.8.4/man"
    PERLBREW_PATH="/home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.4/bin"
    PERLBREW_PERL="perl-5.8.4"
    PERLBREW_ROOT="/home/njh/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.83"
    PERLBREW_VERSION="0.83"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
  @INC:
    /home/njh/perl5/perlbrew/perls/perl-5.8.4/lib/5.8.4/x86_64-linux-thread-multi
    /home/njh/perl5/perlbrew/perls/perl-5.8.4/lib/5.8.4
    /home/njh/perl5/perlbrew/perls/perl-5.8.4/lib/site_perl/5.8.4/x86_64-linux-thread-multi
    /home/njh/perl5/perlbrew/perls/perl-5.8.4/lib/site_perl/5.8.4
    /home/njh/perl5/perlbrew/perls/perl-5.8.4/lib/site_perl